Degraded performance
Incident Report for Forestry.io
Resolved
This incident has been resolved.
Posted May 22, 2020 - 16:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 22, 2020 - 15:33 UTC
This incident affected: app.forestry.io.