Degraded performance
Incident Report for Forestry.io
Monitoring
Response times have improved and we will continue to monitor performance.
Posted Sep 15, 2021 - 17:38 UTC
Investigating
We are investigating an issue where certain operations like saving content and site imports are taking longer than expected.
Posted Sep 14, 2021 - 17:34 UTC
This incident affects: app.forestry.io.