Longer than normal queue times
Incident Report for Forestry.io
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 05, 2019 - 19:03 UTC
Investigating
We are currently experiencing longer than normal queue times. Additional workers are being spun up to help lighten the load.
Posted 8 months ago. Mar 05, 2019 - 18:30 UTC
This incident affected: app.forestry.io.